Issues with Chrome

Discuss Dolphin's Magnification and Screen Reading products.
Post Reply
LUE42
Posts: 7
Joined: Mon Sep 09, 2019 12:36 pm

Issues with Chrome

Post by LUE42 » Thu Sep 26, 2019 6:19 pm

Hi,

This is a new install.

I have "focus" for where the mouse moves turned off in Supernova's highlighting options. However, when I load Chrome, the red Focus box is turned on and highlighting various areas/links of the page.

When typing in Edit Boxes, many keys are not working and some are acting differently, such as K is tabbing between links. It does however type properly in the URL bar, just not in the web page. This is happening for multiple web pages.

Everything returns to normal when Supernova is closed.

Any ideas?

Chrome: 75.0.3770.142 (64 bit)
Windows 10 64bit
Supernova 18.04

LUE42
Posts: 7
Joined: Mon Sep 09, 2019 12:36 pm

Re: Issues with Chrome

Post by LUE42 » Thu Sep 26, 2019 6:44 pm

Further info:
It is on a laptop with a full size keyboard (with numeric keypad). lenovo T580

If I set the keyboard to Laptop (universal), it allows me to type IF i hold down the CAPSLOCK key. I connected an external keyboard it worked fine, then I went back and now it is the same.

It is totally stuck in forms mode - H for headings, K for keyboard, etc...

Is there a setting somewhere for where it decides to turn on or off forms mode?

The red box highlight is still always on and needs to turn off if it is turned off in the main highlighting settings.

Thanks

Gareth.Collins-Dolphin
Posts: 54
Joined: Tue Apr 10, 2018 4:57 pm

Re: Issues with Chrome

Post by Gareth.Collins-Dolphin » Thu Sep 26, 2019 8:16 pm

Open SuperNova's "Speech" pull-down menu and select the menu item "Advanced Options".

In SuperNova's Speech Advanced Options dialog box ensure that the "Use Dolphin Cursor automatically" check box in unchecked.

If you're using SuperNova on a web site, then by default SuperNova will automatically create a virtual cursor (which by default looks like a "red box") at the very top left of the web page (i.e. on the very first element of the web page). This is to give speech users the ability to arrow around a web page as if they had a regular text entry caret in it (like you have in Microsoft Word).

This virtual cursor is called the "Dolphin Cursor", by default it looks like a "red box", and enables you to review any part of the web page via speech using the arrow keys on your keyboard and pressing ENTER to active links and controls etc. If you're in Dolphin Cursor mode (for reviewing the web page using speech via the keyboard) and want to type into an edit area you will need to switch from Dolphin Cursor mode to interactive mode (also known as forms mode), then the virtual Dolphin Cursor ("red box") will disappear and you will be able to interact with and enter text into the edit area that the Dolphin Cursor ("red box") is currently on.

If you wish to use your mouse, rather than the special Dolphin Cursor for navigating a web page and filling out forms (and web-based edit areas) then either uncheck the "Use Dolphin Cursor automatically" check box in SuperNova's Speech Advanced Options dialog box, or press LEFT CONTROL+4 (and that's 4 across the top of your keyboard and NOT 4 on your num pad). The speech should say "Dolphin Cursor - Off". This will switch off the Dolphin Cursor and now your mouse will take precedence over the Dolphin Cursor. You will then be able to just click in an edit area with the mouse and fill out a form as you wish. If you want to revert to the Dolphin Cursor in order to review the web page line by line or letter by letter via speech you can just press LEFT CONTROL+4 again to switch back on the Dolphin Cursor.

If you want to fill out a form using the Dolphin Cursor and the Dolphin Cursor is currently switched on then you can either press E to make SuperNova's Dolphin Cursor jump to the next edit area on the web page and automatically switch from Dolphin Cursor mode to forms mode so that you can enter text, or else you can TAB to the edit area, and if it doesn't automatically go into forms mode for you (so that you can enter text) then try pressing ENTER on your keyboard to force SuperNova into forms mode. However, SuperNova should automatically go into forms mode when the Dolphin Cursor is tabbed onto an edit area (providing you have "Auto Forms Mode" switched on. This can be toggled on and off using CAPS LOCK+ENTER on the main keyboard). The speech should say "Auto Forms Mode - On" or "Auto Forms Mode - Off".

There's also a video tutorial on our web site explaining the concept of the Dolphin Cursor that you might find educational:
https://yourdolphin.com/en-gb/support/videos/playlist?id=10&vid=107

Post Reply